Adobe Creative Cloud to stop support 10.8

The next major release of Creative Cloud will drop the support of OS X 10.8. The new requirement will be Mac OS X 10.9 or higher.

If you’re running an older version of Mac OS X, such as 10.7 or 10.8, you can continue to run and install current and previous versions of the Creative Cloud applications, but will not be able to install or run the next major release of the Creative Cloud desktop applications until you upgrade to a supported version of OS X.

OS X 10.10 Yosemite is a free update for all Mac user if the hardware supports.

Source: An Update: Creative Cloud and Support for Mac OS X


Posted by Antony at April 27, 2015 9:36 PM

>> more MacCentre701 April 2015 reports.